Resolved
Execution latencies are back to normal across all customers, and the incident is now resolved.
Identified
We’re investigating execution slowness affecting a subset of customers, where steps may be delayed by a few seconds to a couple of minutes in the worst cases, caused by elevated memory usage on one of our shards.