Resolved
Metrics in the UI are now restored. Users may notice metrics data continue to be unavailable during the time of the incident, from the timeframe 7/16/26 15:45 UTC until approximately 7/16/26 21:07 UTC
Monitoring
A fix has been deployed and we're monitoring the system to ensure the system is fully operational.
We confirmed all executions were functioning as expected, so this only impacts the metrics on the dashboard.
Investigating
We are actively investigating an issue with our metrics service. Metrics displayed in the Inngest UI may not be up to date, but core platform functionality is unaffected and function execution is operating normally. We will provide further updates as we identify the cause and resolve the issue.