Resolved
The incident is now resolved and the system is full operational.
Monitoring
The new servers have been brought online to increase capacity and we are monitoring as they are introduced into our usage pool. Function execution on all shards is performing as expected, but we are continuing to monitor this closely throughout the coming hours.
Identified
We have identified the issue with some problem servers groups that reached saturation. These servers have been isolated and removed from the usage pool. The system is stable now as we bring additional capacity online for redundancy and overhead.
Investigating
We are actively investigating an issue with elevated latency for function execution for some queue shards. We will provider further updates as we identify the cause and resolve the issue.