Delayed function execution
Resolved·Degraded performance

After an extended monitoring period, function execution has returned to normal rates across all queue shards. During this issue, only a subset of users were affected on part of our infrastructure. Our infrastructure team is in the midst of rolling out additional system capacity going forward.

Mon, Feb 9, 2026, 10:50 PM
(1 day ago)
·
Affected components
Function execution
Updates

Resolved

After an extended monitoring period, function execution has returned to normal rates across all queue shards. During this issue, only a subset of users were affected on part of our infrastructure. Our infrastructure team is in the midst of rolling out additional system capacity going forward.

Mon, Feb 9, 2026, 10:50 PM

Identified

Function execution delays have returned for a subset of users. As we mitigated issues from earlier, some queue related slowness has returned affecting a subset of users running on certain shards.

Mon, Feb 9, 2026, 09:39 PM(1 hour earlier)

Resolved

The incident is now resolved and the system is full operational.

Mon, Feb 9, 2026, 06:13 PM(3 hours earlier)

Monitoring

We scaled up the infrastructure served the affected subset of customers, which will begin to reduce latency to normal levels.

Mon, Feb 9, 2026, 03:52 PM(2 hours earlier)

Investigating

We are actively investigating delayed function execution.

Mon, Feb 9, 2026, 03:31 PM(21 minutes earlier)