Delayed execution and observability metrics
Resolved·Degraded performance

The incident is now resolved and the system is full operational.

During this incident the system experienced a backlog in scheduling new runs and event data ingestion for the Inngest dashboard was delayed.

The root cause was due to an issue with our internal event streams brokers which power internal event ingestion, run trace data ingestion and metrics ingestion. This caused delays in other data in the dashboard as well.

Sat, Jan 17, 2026, 09:28 AM
(4 days ago)
·
Affected components
Function execution
Updates

Resolved

The incident is now resolved and the system is full operational.

During this incident the system experienced a backlog in scheduling new runs and event data ingestion for the Inngest dashboard was delayed.

The root cause was due to an issue with our internal event streams brokers which power internal event ingestion, run trace data ingestion and metrics ingestion. This caused delays in other data in the dashboard as well.

Sat, Jan 17, 2026, 09:28 AM

Monitoring

A fix has been deployed and we're monitoring the system to ensure the system is fully operational.

Sat, Jan 17, 2026, 09:06 AM(22 minutes earlier)

Investigating

We are actively investigating an issue with delayed execution. We will provider further updates as we identify the cause and resolve the issue.

Sat, Jan 17, 2026, 08:35 AM(31 minutes earlier)