Degraded function execution performance
Resolved·Degraded performance

The incident is now resolved and the system is full operational.

Tue, Jan 13, 2026, 10:15 AM
(1 week ago)
·
Affected components
Function execution
Updates

Resolved

The incident is now resolved and the system is full operational.

Tue, Jan 13, 2026, 10:15 AM

Monitoring

A fix has been deployed, and we are seeing backlogged executions begin to catch up.

Tue, Jan 13, 2026, 10:00 AM(15 minutes earlier)

Investigating

We are actively investigating execution performance degradation on our workers that appears to be limited to a subset of users, primarily on our free-tier infrastructure.

Tue, Jan 13, 2026, 04:49 AM(5 hours earlier)