Resolved
The observability pipeline is caught up and run statuses should all be up to date now.
To clarify, function execution itself was not affected during this incident.
Identified
The team is rolling out a fix for observability materialized views in effort to fix the backlog in the o11y pipeline.
Investigating
We are investigating delays in our observability pipeline in our dashboard and API resulting in many runs appearing as "Queued" or "Running" when they have completed. We are experiencing higher volume than typical on the observability part of our system.
Function execution is behaving as expected.