Inngest Dashboard Not Loading Properly
Resolved·Partial outage

The incident is now resolved and the system is full operational. We’ve discovered that some database transactions while syncing apps to Inngest were causing conflicts with large app updates. We’re continuing an existing project to refactor this logic out of the API to avoid this issue in the future.

Fri, Oct 31, 2025, 08:27 PM
(4 days ago)
·
Affected components
Inngest Dashboard
Updates

Resolved

The incident is now resolved and the system is full operational. We’ve discovered that some database transactions while syncing apps to Inngest were causing conflicts with large app updates. We’re continuing an existing project to refactor this logic out of the API to avoid this issue in the future.

Fri, Oct 31, 2025, 08:27 PM

Monitoring

A fix has been deployed and we're monitoring the system to ensure the system is fully operational. The dashboard is operational.

No data was lost during the time period, it did not effect other parts of the system.

Fri, Oct 31, 2025, 06:44 PM(1 hour earlier)

Investigating

We are actively investigating an issue with our Inngest Dashboard. We will provider further updates as we identify the cause and resolve the issue. Executions and Function runs are not affected by this incident.

Fri, Oct 31, 2025, 05:30 PM(1 hour earlier)