Delayed scheduling and execution
Monitoring·Degraded performance

Additional database optimizations have been released which has reduced latency on function execution to normal levels. We continue to monitor and have several further optimizations that we'll release throughout the coming days.

Tue, Oct 21, 2025, 06:02 PM
(10 hours ago)
·
Affected components
Function execution
Inngest Dashboard
API (REST and GraphQL)
Updates

Monitoring

Additional database optimizations have been released which has reduced latency on function execution to normal levels. We continue to monitor and have several further optimizations that we'll release throughout the coming days.

Tue, Oct 21, 2025, 06:02 PM

Identified

There is an ongoing investigation into function execution latency.

Tue, Oct 21, 2025, 04:50 PM(1 hour earlier)

Resolved

The incident is now resolved and the system is full operational. There are not steps required to recover as no data loss or issues should have been created other than system latency.

Tue, Oct 21, 2025, 01:45 PM(3 hours earlier)

Monitoring

We have deployed an improvement to optimize our database indexes resulting in a significant performance increase. The system is performing as expected and we continue to monitor the system.

Tue, Oct 21, 2025, 01:07 PM(38 minutes earlier)

Identified

We have identified the cause of the issue. We're actively working on implementing a fix to resume normal operation of the system.

Tue, Oct 21, 2025, 12:36 PM(30 minutes earlier)

Investigating

We are actively investigating an issue with scheduling delays and execution, as well as dashboard performance. We will provider further updates as we identify the cause and resolve the issue. No impact on event ingestion confirmed at the moment.

Tue, Oct 21, 2025, 10:51 AM(1 hour earlier)