Resolved
The incident is now resolved and the system is full operational. A database issue caused a delay for some dashboard API reqeusts.
Identified
We have identified the cause of the issue. We're actively working on implementing a fix to resume normal operation of the system.