REST API returning stale data
Resolved·Degraded performance

The incident is now resolved and the system is full operational.

Mon, Oct 20, 2025, 03:33 PM
(1 day ago)
·
Affected components
API (REST and GraphQL)
Updates

Resolved

The incident is now resolved and the system is full operational.

Mon, Oct 20, 2025, 03:33 PM

Monitoring

A fix has been deployed and we're monitoring the system to ensure the system is fully operational.

Fri, Oct 17, 2025, 07:45 PM(2 days earlier)

Identified

We have identified the cause of the issue. We're actively working on implementing a fix to resume normal operation of the system.

Thu, Oct 16, 2025, 01:28 PM(1 day earlier)

Identified

We have identified an issue affecting our REST API, where responses may return outdated data. As part of our transition to a new tracing pipeline for the Inngest Dashboard, the REST API has not yet been fully aligned with this infrastructure, resulting in stale event and run information.

We are actively working to resolve this and will provide updates as progress is made. In the meantime, for the most accurate and up-to-date information, we recommend using the Inngest Dashboard.

Tue, Oct 14, 2025, 09:25 PM(1 day earlier)