Resolved
Resolve as of 4pm PT. We've been monitoring latency within the past 2 hours and have resumed normal execution
Monitoring
A limited set of paid customer accounts are experiencing increased latency in queued functions and steps. Our team has released changes to our system to alleviate the slowness and they continue to monitor the situation. Enterprise customers are not affected.