Function execution outage
Resolved·Full outage

The incident is now resolved and the system is full operational.

Thu, Aug 28, 2025, 05:58 AM
(3 days ago)
·
Affected components
Function execution
Updates

Resolved

The incident is now resolved and the system is full operational.

Thu, Aug 28, 2025, 05:58 AM

Monitoring

Our infrastructure provider has provided an update and the network connection between our two cloud providers has been restored. Function execution has resumed as of 3:41 UTC August 28th. We continue to monitor the system and remaining in contact with our infra provider as they monitor the solution.

The system is beginning to work through the backlog of events received during the partial outage.

Thu, Aug 28, 2025, 03:54 AM(2 hours earlier)

Identified

We've identified an issue related to the networking between our Kubernetes cluster and AWS. Our infrastructure provider is actively working on resolving this networking issue and we are in direct contact with them.

Event ingestion is continuing to accept events, so no events sent are dropped during this outage.

Thu, Aug 28, 2025, 03:39 AM(14 minutes earlier)

Investigating

We are actively investigating an issue with function execution. We will provider further updates as we identify the cause and resolve the issue.

Thu, Aug 28, 2025, 02:51 AM(48 minutes earlier)