Internal DNS issue causing issues with function execution
Resolved·Partial outage

The system is fully operational. Post-mortem corrective actions have begun.

Thu, Jul 17, 2025, 02:32 PM
(6 months ago)
·
Affected components
Function execution
Updates

Resolved

The system is fully operational. Post-mortem corrective actions have begun.

Thu, Jul 17, 2025, 02:32 PM

Monitoring

Function execution has been fully restored. We continue to monitor the system to ensure that behavior is as expected.

Thu, Jul 17, 2025, 01:59 PM(32 minutes earlier)

Monitoring

A fix has been put in place for internal DNS and the system is beginning recovery.

Thu, Jul 17, 2025, 01:48 PM(10 minutes earlier)

Identified

We're rolling out changes to restore internal DNS now.

Thu, Jul 17, 2025, 01:42 PM

Identified

An issue with internal DNS servers began at 13:17 UTC causing internal and outbound networking issues. We are working to determine the root cause and deploy a fix.

Thu, Jul 17, 2025, 01:17 PM(25 minutes earlier)