Event API - Event ingestion delays
Resolved·Partial outage

PubSub has been stable for hours after updates from the GCP team. The incident has been resolved.

Wed, Jan 8, 2025, 10:17 PM
(5 months ago)
·
Affected components
Event API
Updates

Resolved

PubSub has been stable for hours after updates from the GCP team. The incident has been resolved.

Wed, Jan 8, 2025, 10:17 PM

Monitoring

Google Cloud has notified us and shared publicly some details about the Pub/Sub outage. We are continuing to work with their team to understand the scope of the outage and resolutions.

https://status.cloud.google.com/incidents/ghMho2Gka33Exr9UNavz

The Inngest Event API is has now been fully operational for 48 minutes (15:33 UTC) without another issue.

Wed, Jan 8, 2025, 04:21 PM(5 hours earlier)

Identified

Event API and the rest of the Inngest system is fully functioning again as of 15:33 UTC. Issues began at 15:14 UTC. We are actively working with GCP's team to determine the root cause of the issues.

Wed, Jan 8, 2025, 03:49 PM(32 minutes earlier)

Identified

We've identified issues with Google Cloud PubSub, which we use to power event ingestion globally. This looks like a downstream provider issue. We are working to get in touch with GCP to determine resolution.

Wed, Jan 8, 2025, 03:39 PM

Investigating

Event API is coming back online intermittently. Investigating in ongoing.

Wed, Jan 8, 2025, 03:36 PM

Investigating

We are investigating an issue with event ingestion with our internal pub sub stream.

Wed, Jan 8, 2025, 03:32 PM