Resolved
The incident is now resolved.
Monitoring
A fix has been deployed via Clerk and we're monitoring the system to ensure the system is fully operational.
Identified
We have identified the cause of the issue and are waiting for the downstream provider to implement their fix