Monitoring
A fix has been deployed and we're monitoring the system to ensure the system is fully operational.
Investigating
We are actively investigating an issue with our backing database for several of our dashboard pages. REST API and Function execution are not currently impacted.